PayPal subscriptions are not currently working on Envato Elements
Incident Report for Envato
Resolved
We have deployed a fix and users can once again pay for an Elements subscription using PayPal
Posted Mar 08, 2018 - 16:54 AEDT
Identified
We have identified an issue using PayPal as a payment method while subscribing for a new subscription on Envato Elements.
We are currently working on a fix and should have it deployed within the hour.
Credit Card payments are not impacted.
Posted Mar 08, 2018 - 16:17 AEDT