Problem processing payments on Envato Studio
Incident Report for Envato
Resolved
The problem with Envato Studio payment processing has been resolved. Sorry for any inconvenience.
Posted Feb 20, 2018 - 06:14 AEDT
Monitoring
We are experiencing issues processing payments from some Envato Studio customers, due to an upstream problem with our payment gateway. We'll post here for further updates.
Posted Feb 20, 2018 - 01:52 AEDT