Elements subscription processing delays
Incident Report for Envato
Resolved
The backlog in subscription processing has now been cleared, and this incident is resolved.
Posted Feb 24, 2021 - 09:44 AEDT
Monitoring
We have implemented a fix to improve the processing speed, and expect the backlog in subscription processing to be cleared within the next hour.
Posted Feb 24, 2021 - 09:15 AEDT
Identified
The delays to subscription processing are decreasing but the backlog may take some time to clear. We continue to investigate ways to improve the situation.
Posted Feb 24, 2021 - 08:15 AEDT
Investigating
We've identified an issue with delays when creating or changing subscriptions. We are currently investigating.
Posted Feb 24, 2021 - 07:06 AEDT
This incident affected: Elements.