Elements Outage
Incident Report for Envato
Resolved
The issue has been resolved.
Posted Aug 05, 2022 - 18:03 AEST
Investigating
We are currently investigating the issue
Posted Aug 05, 2022 - 17:56 AEST
This incident affected: Elements.