Items are not downloading correctly
Incident Report for Envato
Resolved
Items can be downloaded correctly again
Posted 3 months ago. Jan 30, 2019 - 07:55 AEDT
Update
We are continuing to investigate this issue.
Posted 3 months ago. Jan 30, 2019 - 07:48 AEDT
Investigating
We are currently investigating an issue with some items not Elements downloading correctly
Posted 3 months ago. Jan 30, 2019 - 07:38 AEDT
This incident affected: Elements.