Author Sign Up flow is broken
Incident Report for Envato
Resolved
This incident has been resolved.
Posted about 1 month ago. Mar 21, 2019 - 23:40 AEDT
Identified
An issue preventing users from completing the Author Sign Up flow has been identified and a fix is underway
Posted about 1 month ago. Mar 21, 2019 - 23:26 AEDT
This incident affected: Author Services (Author Sign Up).