Envato Studio server maintenance
Incident Report for Envato
Resolved
This incident has been resolved.
Posted Jan 06, 2020 - 13:18 AEDT
Update
Maintenance is now complete.
Posted Jan 06, 2020 - 13:17 AEDT
Monitoring
Envato Studio will be unavailable for approximately 10 minutes while we perform server updates.
Posted Jan 06, 2020 - 13:04 AEDT
This incident affected: Studio.