Envato Sites Contact Form Service
Incident Report for Envato
Resolved
This incident has been resolved.
Posted 2 months ago. Feb 20, 2019 - 20:50 AEDT
Update
We are continuing to investigate this issue.
Posted 2 months ago. Feb 20, 2019 - 16:16 AEDT
Investigating
We are experiencing some disruptions to the service that Envato Sites uses to send emails for customer contact forms. If you have any issues related to contact forms on your site, please contact customer success.
Posted 2 months ago. Feb 20, 2019 - 16:16 AEDT
This incident affected: Sites.