Item Detail Pages Down
Incident Report for Envato
Resolved
The incident has been resolved we will continue to monitor.
Posted Nov 16, 2024 - 12:22 AEDT
Update
The issue has been identified and we are working on a fix.
Posted Nov 16, 2024 - 12:14 AEDT
Update
We are continuing to investigate this issue.
Posted Nov 16, 2024 - 11:37 AEDT
Investigating
We are aware of an issue with the detail pages of items on Elements and are investigating. Users are still able to download items from the item grid pages.
Posted Nov 16, 2024 - 11:37 AEDT
This incident affected: Elements.