Credit card payments unavailable
Incident Report for Envato
Resolved
This incident has been resolved.
Posted 10 months ago. Nov 29, 2018 - 00:31 AEDT
Monitoring
Braintree issues seem to have resolved. We have re-enabled Credit card payments through Braintree.
Posted 10 months ago. Nov 28, 2018 - 23:42 AEDT
Investigating
One of our credit card payment gateways, Braintree, is currently experiencing some issues. Credit card payments through Braintree have been disabled while we investigate.
Posted 10 months ago. Nov 28, 2018 - 23:14 AEDT