Issues processing new video items
Incident Report for Envato
Resolved
This incident has been resolved.
Posted Mar 02, 2021 - 11:42 AEDT
Investigating
We have discovered an issue that is preventing new stock video uploads from being processed. We are currently investigating this issue.
Posted Mar 02, 2021 - 11:32 AEDT