Video upload tool outage
Incident Report for Envato
Resolved
Service has been restored
Posted Jan 10, 2018 - 11:03 AEDT
Investigating
Video upload is currently disabled due to an internal issue, we are working to restore service ASAP. We’ll post further updates here. Thanks for your patience.
Posted Jan 10, 2018 - 10:37 AEDT