Signup on Market Sites Blocked During Checkout
Incident Report for Envato
Resolved
This incident has now been resolved. We apologise for any inconvenience.
Posted May 15, 2018 - 15:23 AEST
Identified
We have identified an issue where signing up on a market site is blocked during checkout. A fix will be released shortly.
Posted May 15, 2018 - 14:39 AEST