Elements earnings calculations paused
Incident Report for Envato
Resolved
This incident has been resolved.
Posted Jul 18, 2022 - 09:47 AEST
Monitoring
Elements earnings calculations are temporarily paused while the system recovers from an incident with an upstream provider.
Posted Jul 15, 2022 - 11:01 AEST
This incident affected: Elements.