Author Dashboard maintenance taking longer than expected
Incident Report for Envato
Resolved
Maintenance is now complete.
Posted Aug 01, 2023 - 17:13 AEST
Investigating
We apologise for the inconvenience but the scheduled maintenance is taking a little bit longer than anticipated.
Posted Aug 01, 2023 - 16:56 AEST
This incident affected: Author Tools (Author Tooling).