Elements is offline
Incident Report for Envato
Resolved
This incident has been resolved.
Posted 3 months ago. Jan 23, 2019 - 16:21 AEDT
Monitoring
We believe the issue has been resolved but are continuing to monitor performance.
Posted 3 months ago. Jan 23, 2019 - 16:01 AEDT
Identified
Elements is currently offline and we are investigating
Posted 3 months ago. Jan 23, 2019 - 15:56 AEDT
This incident affected: Elements.