Video submissions
Incident Report for Envato
Resolved
This incident has been resolved.
Posted Oct 30, 2019 - 15:05 AEDT
Investigating
We are currently investigating reports of delays related to submitting video content.
Posted Oct 30, 2019 - 13:50 AEDT
This incident affected: Author Services (Video Upload Tool, Video Upload FTP).