An incident causing author sign ups to fail has occurred
Incident Report for Envato
Resolved
This incident has been resolved.
Posted 4 months ago. May 15, 2019 - 06:59 AEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 4 months ago. May 15, 2019 - 06:49 AEST
Investigating
We are currently investigating this issue.
Posted 4 months ago. May 15, 2019 - 06:45 AEST
This incident affected: Author Services (Author Sign Up).