Author sign up is broken
Incident Report for Envato
Resolved
This incident has been resolved.
Posted 6 months ago. Feb 15, 2019 - 23:57 AEDT
Investigating
The author sign-up flow at https://author.envato.com/join appears not to register new authors. The sign-up form is functional but in the end it just redirects to the Market homepage instead of the author dashboard and fails to promote accounts to author status. We're investigating.
Posted 6 months ago. Feb 15, 2019 - 21:20 AEDT
This incident affected: Author Services (Author Sign Up).