Some Envato account emails are delayed
Incident Report for Envato
Resolved
The emails are still delivering. The issue appears to be resolved.
Posted 4 months ago. Feb 05, 2019 - 21:09 AEDT
Monitoring
All Envato account emails that failed to send are being automatically retried and are being delivered successfully.
Posted 4 months ago. Feb 05, 2019 - 12:34 AEDT
Identified
Our transactional email provider is still working to restore service.
Posted 4 months ago. Feb 05, 2019 - 11:07 AEDT
Investigating
Emails for password reset and account confirmation are currently delayed. An investigation is underway.
Posted 4 months ago. Feb 05, 2019 - 09:03 AEDT
This incident affected: SSO.