Elements is down
Incident Report for Envato
Resolved
The incident has been resolved and Elements is functioning as normal.
Posted 5 months ago. May 10, 2019 - 13:40 AEST
Monitoring
A fix has been implemented and we are monitoring the status.
Posted 5 months ago. May 10, 2019 - 13:22 AEST
Investigating
We are currently investigating the issue.
Posted 5 months ago. May 10, 2019 - 13:08 AEST
This incident affected: Elements.