Photo & 3D Author Tools – Item editing unavailable

Incident Report for Envato

Resolved

This incident has been resolved.
Posted May 09, 2025 - 15:16 AEST

Investigating

We have identified the issue and we are working to resolve this.
Posted May 09, 2025 - 11:33 AEST
This incident affected: Author Tools (Portfolio Management, Internal Review Tools).