Elements: Subscription errors
Incident Report for Envato
Resolved
Our subscription provider has declared their issue resolved, and we are no longer seeing this affect Elements users.
Posted Oct 15, 2019 - 14:07 AEDT
Investigating
A few Elements users may experience problems when subscribing due to issues with our subscription provider. We are monitoring the situation and will provide an update soon.
Posted Oct 15, 2019 - 13:40 AEDT
This incident affected: Elements.