Delayed item reviews and updates
Incident Report for Envato
Resolved
This incident has been resolved.
Posted Jun 24, 2020 - 17:00 AEST
Identified
We are experiencing delays in our backend processing system. There will be delays in item reviews and the propagation of item updates to the Elements storefront.

The cause has been identified, and we are working on a fix.
Posted Jun 24, 2020 - 15:54 AEST
This incident affected: Author Services (Elements Author Tools).