Missing Items
Incident Report for Envato
Resolved
We have found the issue and restored all items on Elements.
Posted Jul 28, 2020 - 14:34 AEST
Investigating
We are aware of missing items on Elements and are currently investigating the issue.
Posted Jul 28, 2020 - 13:27 AEST
This incident affected: Elements.