Unable to process subscriptions and access user account pages
Incident Report for Envato
Resolved
This incident has been resolved.
Posted May 11, 2023 - 11:23 AEST
Update
The third party has fixed the issue and all systems are operational.
Posted May 11, 2023 - 11:22 AEST
Update
We are continuing to investigate this issue.
Posted May 11, 2023 - 10:50 AEST
Investigating
We are currently investigating the issue, with a third party provide that may be causing the issues with customers ability to sign up for new subscriptions and to access their account page.

We will update at 11:30AEST
Posted May 11, 2023 - 10:49 AEST
This incident affected: Elements and Envato Account.