Unable to access Elements Author Portfolio pages
Incident Report for Envato
Resolved
This incident has now been resolved.
Posted Mar 24, 2023 - 09:42 AEDT
Monitoring
A fix has been applied and pages appear to be restored. Monitoring is underway.
Posted Mar 24, 2023 - 09:12 AEDT
Identified
We have identified the root cause and are working on a fix.
Posted Mar 24, 2023 - 08:58 AEDT
This incident affected: Elements.