Elements Subscriptions
Incident Report for Envato
Resolved
This incident has been resolved.
Posted about 1 month ago. Mar 20, 2019 - 13:45 AEDT
Monitoring
A fix has been implemented and we are monitoring the results
Posted about 1 month ago. Mar 20, 2019 - 10:34 AEDT
Investigating
We are currently investigating this issue.
Posted about 1 month ago. Mar 20, 2019 - 09:48 AEDT
Identified
We've identified a problem with our subscription system and are working to resolve it now. Customers will not be able to subscribe or modify their subscription until this issue is resolved.
Posted about 1 month ago. Mar 20, 2019 - 09:26 AEDT
This incident affected: Elements.